<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.sentinelprogress.com/xmlrpc.php" />
<title>Liberty man attends National Gala | Sentinel Progress</title>

<!-- The SEO Framework by Sybre Waaijer -->
<meta name="description" content="LIBERTY — The Children’s Tumor Foundation recently hosted the National Gala in New York City. This annual event draws philanthropists, donors, fundraisers&#8230;" />
<meta property="og:image" content="https://s24516.pcdn.co/wp-content/uploads/2019/11/web1_brown2.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="427" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Liberty man attends National Gala | Sentinel Progress" />
<meta property="og:description" content="LIBERTY — The Children’s Tumor Foundation recently hosted the National Gala in New York City. This annual event draws philanthropists, donors, fundraisers, researchers, clinicians&#8230;" />
<meta property="og:url" content="https://www.sentinelprogress.com/top-stories/13429/liberty-man-attends-national-gala" />
<meta property="og:site_name" content="Sentinel Progress" />
<meta property="article:publisher" content="https://www.facebook.com/pages/The-Pickens-Sentinel/206490383408" />
<meta property="article:published_time" content="2019-11-28T20:50+00:00" />
<meta property="article:modified_time" content="2019-11-28T20:50+00:00" />
<meta property="og:updated_time" content="2019-11-28T20:50+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Liberty man attends National Gala | Sentinel Progress" />
<meta name="twitter:description" content="LIBERTY — The Children’s Tumor Foundation recently hosted the National Gala in New York City. This annual event draws philanthropists, donors, fundraisers, researchers, clinicians&#8230;" />
<meta name="twitter:image" content="https://s24516.pcdn.co/wp-content/uploads/2019/11/web1_brown2.jpg" />
<meta name="twitter:image:width" content="640" />
<meta name="twitter:image:height" content="427" />
<link rel="canonical" href="https://www.sentinelprogress.com/top-stories/13429/liberty-man-attends-national-gala" />
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.sentinelprogress.com/","name":"Sentinel Progress"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.sentinelprogress.com/category/top-stories","name":"Top Stories"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.sentinelprogress.com/top-stories/13429/liberty-man-attends-national-gala","name":"Liberty man attends National Gala"}}]}</script>
<!-- / The SEO Framework by Sybre Waaijer | 5.04ms meta | 0.94ms boot -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Sentinel Progress &raquo; Feed" href="https://www.sentinelprogress.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Sentinel Progress &raquo; Comments Feed" href="https://www.sentinelprogress.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Sentinel Progress &raquo; Liberty man attends National Gala Comments Feed" href="https://www.sentinelprogress.com/top-stories/13429/liberty-man-attends-national-gala/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s24516.pcdn.co\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://s24516.pcdn.co/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='simple-staff-list-css'  href='https://s24516.pcdn.co/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css?ver=2.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='staff-list-custom-css-css'  href='https://s24516.pcdn.co/wp-content/themes/mh-magazine/simple-staff-list-custom.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='vfb-pro-css'  href='https://s24516.pcdn.co/wp-content/plugins/vfb-pro/public/assets/css/vfb-style.min.css?ver=2019.05.10' type='text/css' media='all' />
<link rel='stylesheet' id='megamenu-css'  href='https://s24516.pcdn.co/wp-content/uploads/maxmegamenu/style.css?ver=f43f79' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://s24516.pcdn.co/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://s24516.pcdn.co/wp-content/themes/mh-magazine/style.css?ver=3.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://s24516.pcdn.co/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:300,400,400italic,600,700' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://s24516.pcdn.co/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://s24516.pcdn.co/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://s24516.pcdn.co/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.3'></script>
<link rel='https://api.w.org/' href='https://www.sentinelprogress.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sentinelprogress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s24516.pcdn.co/wp-includes/wlwmanifest.xml" /> 
<link rel="alternate" type="application/json+oembed" href="https://www.sentinelprogress.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sentinelprogress.com%2Ftop-stories%2F13429%2Fliberty-man-attends-national-gala" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sentinelprogress.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sentinelprogress.com%2Ftop-stories%2F13429%2Fliberty-man-attends-national-gala&#038;format=xml" />
<style type="text/css">
.mh-widget-layout4 .mh-widget-title { background: #1e73be; background: rgba(30, 115, 190, 0.6); }
.mh-preheader, .mh-wide-layout .mh-subheader, .mh-ticker-title, .mh-main-nav li:hover, .mh-footer-nav, .slicknav_menu, .slicknav_btn, .slicknav_nav .slicknav_item:hover, .slicknav_nav a:hover, .mh-back-to-top, .mh-subheading, .entry-tags .fa, .entry-tags li:hover, .mh-widget-layout2 .mh-widget-title, .mh-widget-layout4 .mh-widget-title-inner, .mh-widget-layout4 .mh-footer-widget-title, .mh-widget-layout5 .mh-widget-title-inner, .mh-widget-layout6 .mh-widget-title, #mh-mobile .flex-control-paging li a.flex-active, .mh-image-caption, .mh-carousel-layout1 .mh-carousel-caption, .mh-tab-button.active, .mh-tab-button.active:hover, .mh-footer-widget .mh-tab-button.active, .mh-social-widget li:hover a, .mh-footer-widget .mh-social-widget li a, .mh-footer-widget .mh-author-bio-widget, .tagcloud a:hover, .mh-widget .tagcloud a:hover, .mh-footer-widget .tagcloud a:hover, .mh-posts-stacked-item .mh-meta, .page-numbers:hover, .mh-loop-pagination .current, .mh-comments-pagination .current, .pagelink, a:hover .pagelink, input[type=submit], #infinite-handle span { background: #1e73be; }
.mh-main-nav-wrap .slicknav_nav ul, blockquote, .mh-widget-layout1 .mh-widget-title, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout5 .mh-widget-title, .mh-widget-layout8 .mh-widget-title:after, #mh-mobile .mh-slider-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-author-bio-widget, .mh-author-bio-title, .mh-author-bio-image-frame, .mh-video-widget, .mh-tab-buttons, textarea:hover, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover { border-color: #1e73be; }
.mh-dropcap, .mh-carousel-layout1 .flex-direction-nav a, .mh-carousel-layout2 .mh-carousel-caption, .mh-posts-digest-small-category, .mh-posts-lineup-more, .bypostauthor .fn:after, .mh-comment-list .comment-reply-link:before, #respond #cancel-comment-reply-link:before { color: #1e73be; }
</style>
<!--[if lt IE 9]>
<script src="https://s24516.pcdn.co/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<link rel="icon" href="https://s24516.pcdn.co/wp-content/uploads/2018/02/cropped-champfav-32x32.png" sizes="32x32" />
<link rel="icon" href="https://s24516.pcdn.co/wp-content/uploads/2018/02/cropped-champfav-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://s24516.pcdn.co/wp-content/uploads/2018/02/cropped-champfav-180x180.png" />
<meta name="msapplication-TileImage" content="https://s24516.pcdn.co/wp-content/uploads/2018/02/cropped-champfav-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			.attachment-mh-magazine-slider{
height: 300px !important;
width: auto !important;
}

@media only screen and (max-width: 600px) {
	div.adblade-dyna.zone-13366 {
		display: none;
	}
}		</style>
		<style type="text/css">/** Mega Menu CSS: fs **/</style>
<script async="async" src="//zdwidget3-bs.sphereup.com/zoomd/SearchUi/Script?clientId=31053513"></script>
</head>
<body data-rsssl=1 id="mh-mobile" class="post-template-default single single-post postid-13429 single-format-standard wp-custom-logo mega-menu-mh-main-nav mh-boxed-layout mh-right-sb mh-loop-layout1 mh-widget-layout1" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<aside class="mh-container mh-header-widget-1">
<div id="custom_html-26" class="widget_text mh-widget mh-header-1 widget_custom_html"><div class="textwidget custom-html-widget"><ins data-revive-zoneid="140" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script></div></div></aside>
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-header-menu-container"><ul id="menu-header-menu" class="menu"><li id="menu-item-9940" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9940"><a href="http://jobmatchnc.com">Jobs</a></li>
<li id="menu-item-9938" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9938"><a href="https://www.sentinelprogress.com/classifieds">Classifieds</a></li>
<li id="menu-item-9951" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9951"><a href="https://itunes.apple.com/us/app/the-pickens-sentinel/id1044695588?mt=8">iPhone/iPad App</a></li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
											<nav class="mh-social-icons mh-social-nav mh-social-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-social-container"><ul id="menu-social" class="menu"><li id="menu-item-9941" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9941"><a href="http://www.facebook.com/pages/The-Pickens-Sentinel/206490383408"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-10228" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10228"><a href="https://www.instagram.com/thesentinelprogress/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Instagram</span></a></li>
</ul></div>						</nav>
									</div>
					</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand">
<a href="https://www.sentinelprogress.com/" class="custom-logo-link" rel="home"><img width="300" height="32" src="https://s24516.pcdn.co/wp-content/uploads/2018/02/cropped-sentinelprog-1.png" class="custom-logo" alt="Sentinel Progress" /></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="custom_html-14" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget">	<ins data-revive-zoneid="60" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
			<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script></div></div></aside>
</div>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div id="mega-menu-wrap-mh_main_nav" class="mega-menu-wrap"><div class="mega-menu-toggle"><div class="mega-toggle-blocks-left"></div><div class="mega-toggle-blocks-center"></div><div class="mega-toggle-blocks-right"><div class='mega-toggle-block mega-menu-toggle-block mega-toggle-block-1' id='mega-toggle-block-1' tabindex='0'><span class='mega-toggle-label' role='button' aria-expanded='false'><span class='mega-toggle-label-closed'>MENU</span><span class='mega-toggle-label-open'>MENU</span></span></div></div></div><ul id="mega-menu-mh_main_nav" class="mega-menu max-mega-menu mega-menu-horizontal mega-no-js" data-event="hover_intent" data-effect="fade_up" data-effect-speed="200" data-effect-mobile="disabled" data-effect-speed-mobile="0" data-mobile-force-width="false" data-second-click="go" data-document-click="collapse" data-vertical-behaviour="standard" data-breakpoint="600" data-unbind="true"><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-2753' id='mega-menu-item-2753'><a class="mega-menu-link" href="http://pickenssentinel.com" aria-haspopup="true" aria-expanded="false" tabindex="0">Home<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2759' id='mega-menu-item-2759'><a class="mega-menu-link" href="https://www.sentinelprogress.com/about-us">About Us</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2760' id='mega-menu-item-2760'><a class="mega-menu-link" href="https://www.sentinelprogress.com/advertise">Advertise</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2761' id='mega-menu-item-2761'><a class="mega-menu-link" href="https://www.sentinelprogress.com/contact-us">Contact Us</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2762' id='mega-menu-item-2762'><a class="mega-menu-link" href="https://www.sentinelprogress.com/sign-up-for-notices">Sign Up For Notices</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2763' id='mega-menu-item-2763'><a class="mega-menu-link" href="https://www.sentinelprogress.com/subscribe">Subscribe</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-2764' id='mega-menu-item-2764'><a class="mega-menu-link" href="https://www.facebook.com/sentinelprogress/">The Sentinel-Progress on Facebook</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-2750' id='mega-menu-item-2750'><a class="mega-menu-link" href="https://www.sentinelprogress.com/category/news" aria-haspopup="true" aria-expanded="false" tabindex="0">News<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2765' id='mega-menu-item-2765'><a class="mega-menu-link" href="https://www.sentinelprogress.com/archives">Archives</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2766' id='mega-menu-item-2766'><a class="mega-menu-link" href="https://www.sentinelprogress.com/circulars">Circulars</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-2767' id='mega-menu-item-2767'><a class="mega-menu-link" href="http://myinvestkit.com/pickenssentinel.com">Finance</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-4841' id='mega-menu-item-4841'><a class="mega-menu-link" href="https://www.sentinelprogress.com/president">President Trump</a></li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-9948' id='mega-menu-item-9948'><a class="mega-menu-link" href="https://www.sentinelprogress.com/category/special-sections">Special Sections</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2768' id='mega-menu-item-2768'><a class="mega-menu-link" href="https://www.sentinelprogress.com/formnewstip">News Tip</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2769' id='mega-menu-item-2769'><a class="mega-menu-link" href="https://www.sentinelprogress.com/online-community">Online Community</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2770' id='mega-menu-item-2770'><a class="mega-menu-link" href="https://www.sentinelprogress.com/onlineforms">Online Forms</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-2752' id='mega-menu-item-2752'><a class="mega-menu-link" href="https://www.sentinelprogress.com/category/sports" aria-haspopup="true" aria-expanded="false" tabindex="0">Sports<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2772' id='mega-menu-item-2772'><a class="mega-menu-link" href="https://www.sentinelprogress.com/formscores">Submit Scores</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2773' id='mega-menu-item-2773'><a class="mega-menu-link" href="https://www.sentinelprogress.com/formsportsnews">Submit Sports News</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-4147' id='mega-menu-item-4147'><a class="mega-menu-link" href="http://pro32.ap.org/sentinelprogress">Pro32</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-4148' id='mega-menu-item-4148'><a class="mega-menu-link" href="http://wintergames.ap.org/sentinelprogress">AP Olympics Coverage</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-4149' id='mega-menu-item-4149'><a class="mega-menu-link" href="http://racing.ap.org/sentinelprogress">Auto Racing</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-4150' id='mega-menu-item-4150'><a class="mega-menu-link" href="http://collegebasketball.ap.org/sentinelprogress">College Basketball</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-4151' id='mega-menu-item-4151'><a class="mega-menu-link" href="http://collegefootball.ap.org/sentinelprogress">College Football</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-align-bottom-left mega-menu-flyout mega-menu-item-2756' id='mega-menu-item-2756'><a class="mega-menu-link" href="http://www.legacy.com/obituaries/pickenssentinel" tabindex="0">Obituaries</a></li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-2751' id='mega-menu-item-2751'><a class="mega-menu-link" href="https://www.sentinelprogress.com/category/opinion" aria-haspopup="true" aria-expanded="false" tabindex="0">Opinion<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2774' id='mega-menu-item-2774'><a class="mega-menu-link" href="https://www.sentinelprogress.com/formeditor">Letter To The Editor</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-2749' id='mega-menu-item-2749'><a class="mega-menu-link" href="https://www.sentinelprogress.com/category/features" aria-haspopup="true" aria-expanded="false" tabindex="0">Features<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-3835' id='mega-menu-item-3835'><a class="mega-menu-link" href="https://www.sentinelprogress.com/games">Games & Puzzles</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2776' id='mega-menu-item-2776'><a class="mega-menu-link" href="https://www.sentinelprogress.com/contests">Contests</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2775' id='mega-menu-item-2775'><a class="mega-menu-link" href="https://www.sentinelprogress.com/comics">Comics</a></li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-9947' id='mega-menu-item-9947'><a class="mega-menu-link" href="https://www.sentinelprogress.com/category/special-sections">Special Sections</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2778' id='mega-menu-item-2778'><a class="mega-menu-link" href="https://www.sentinelprogress.com/horoscopes">Horoscopes</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2780' id='mega-menu-item-2780'><a class="mega-menu-link" href="https://www.sentinelprogress.com/formanniversary">Submit Anniversary</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2781' id='mega-menu-item-2781'><a class="mega-menu-link" href="https://www.sentinelprogress.com/formbirth">Submit Birth</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2782' id='mega-menu-item-2782'><a class="mega-menu-link" href="https://www.sentinelprogress.com/formbirthday">Submit Birthday</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2783' id='mega-menu-item-2783'><a class="mega-menu-link" href="https://www.sentinelprogress.com/formengagement">Submit Engagement</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2784' id='mega-menu-item-2784'><a class="mega-menu-link" href="https://www.sentinelprogress.com/formwedding">Submit Wedding</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-align-bottom-left mega-menu-flyout mega-menu-item-2754' id='mega-menu-item-2754'><a class="mega-menu-link" href="https://www.sentinelprogress.com/calendar" tabindex="0">Calendar</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-2755' id='mega-menu-item-2755'><a class="mega-menu-link" href="https://www.sentinelprogress.com/entertainment" aria-haspopup="true" aria-expanded="false" tabindex="0">Entertainment<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2790' id='mega-menu-item-2790'><a class="mega-menu-link" href="https://www.sentinelprogress.com/tvlistings">TV Listings</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2788' id='mega-menu-item-2788'><a class="mega-menu-link" href="https://www.sentinelprogress.com/tvsoaps">Soaps</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2791' id='mega-menu-item-2791'><a class="mega-menu-link" href="https://www.sentinelprogress.com/tvnews">TV News</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2793' id='mega-menu-item-2793'><a class="mega-menu-link" href="https://www.sentinelprogress.com/tvsports">TV Sports</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2794' id='mega-menu-item-2794'><a class="mega-menu-link" href="https://www.sentinelprogress.com/tvtalk">TV Talk</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2785' id='mega-menu-item-2785'><a class="mega-menu-link" href="https://www.sentinelprogress.com/tvgames">Games</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2786' id='mega-menu-item-2786'><a class="mega-menu-link" href="https://www.sentinelprogress.com/tvmovies">Movies</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2787' id='mega-menu-item-2787'><a class="mega-menu-link" href="https://www.sentinelprogress.com/tvqa">Q &#038; A</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2789' id='mega-menu-item-2789'><a class="mega-menu-link" href="https://www.sentinelprogress.com/tvbestbets">TV Best Bets</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2792' id='mega-menu-item-2792'><a class="mega-menu-link" href="https://www.sentinelprogress.com/tvsearch">TV Search</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-2795' id='mega-menu-item-2795'><a class="mega-menu-link" href="https://www.sentinelprogress.com/tvvideo">TV Video</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-9490' id='mega-menu-item-9490'><a class="mega-menu-link" href="https://www.sentinelprogress.com/advertise" aria-haspopup="true" aria-expanded="false" tabindex="0">Advertise<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9488' id='mega-menu-item-9488'><a class="mega-menu-link" href="https://www.sentinelprogress.com/advertiser-pay">Advertiser Pay</a></li></ul>
</li></ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<div class="mh-header-ticker mh-header-ticker-bottom">
							<div class="mh-ticker-bottom">
			<div class="mh-ticker-title mh-ticker-title-bottom">
			News Ticker<i class="fa fa-chevron-right"></i>		</div>
		<div class="mh-ticker-content mh-ticker-content-bottom">
		<ul id="mh-ticker-loop-bottom">				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.sentinelprogress.com/special-sections/13782/2020-medical-guide" title="2020 Medical Guide">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ February 29, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							2020 Medical Guide						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Special Sections							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.sentinelprogress.com/news/13849/tigers-fend-off-morgan-state" title="Tigers fend off Morgan State">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ February 27, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Tigers fend off Morgan State						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																News							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.sentinelprogress.com/sports/13847/lady-blue-flame-basketball-season-was-full-of-highlights" title="Lady Blue Flame basketball season was full of highlights">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ February 27, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Lady Blue Flame basketball season was full of highlights						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Sports							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.sentinelprogress.com/opinion/13843/kids-have-to-make-names-for-themselves" title="Kids have to make names for themselves">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ February 27, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Kids have to make names for themselves						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Opinion							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.sentinelprogress.com/opinion/columns/13841/a-roadmap-to-your-savings-journey" title="A roadmap to your savings journey">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ February 27, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							A roadmap to your savings journey						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Columns							</span>
											</a>
				</li>		</ul>
	</div>
</div>						</div>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<aside zoomdSearch='{"trigger":"OnClick"}' class="mh-header-search mh-header-search-bottom">
							<form role="search" method="get" class="search-form" action="https://www.sentinelprogress.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.sentinelprogress.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.sentinelprogress.com/category/top-stories" itemprop="url"><span itemprop="title">Top Stories</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>Liberty man attends National Gala</nav>
<style>
.neFileBlock{
	display:none;
}
</style>
<article id="post-13429" class="post-13429 post type-post status-publish format-standard has-post-thumbnail hentry category-top-stories">
	<header class="entry-header clearfix"><h1 class="entry-title">Liberty man attends National Gala</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.sentinelprogress.com/date/2019/11">November 28, 2019</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.sentinelprogress.com/author/englewoodindependent-2">Pickens Sentinel</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.sentinelprogress.com/category/top-stories" rel="category tag">Top Stories</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.sentinelprogress.com/top-stories/13429/liberty-man-attends-national-gala#respond" class="mh-comment-count-link" ><span class="dsq-postid" data-dsqidentifier="13429 https://www.sentinelprogress.com/?p=13429">0</span></a></span>
</div>
				<div id="byline" style="margin-left: 5px; margin-top: 5px;"><b>By: By Kasie Strickland - kstrickland@cmpapers.com</b></div>
			</header>
		<div class="entry-content clearfix">
<figure class="entry-thumbnail">
<img src="https://s24516.pcdn.co/wp-content/uploads/2019/11/web1_brown2-640x381.jpg" alt="" title="web1_brown2.jpg" />
</figure>
<div class="mh-social-top">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.sentinelprogress.com%2Ftop-stories%2F13429%2Fliberty-man-attends-national-gala&t=Liberty+man+attends+National+Gala', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Liberty+man+attends+National+Gala:&url=https%3A%2F%2Fwww.sentinelprogress.com%2Ftop-stories%2F13429%2Fliberty-man-attends-national-gala', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.sentinelprogress.com%2Ftop-stories%2F13429%2Fliberty-man-attends-national-gala&media=https://www.sentinelprogress.com/wp-content/uploads/2019/11/web1_brown2.jpg&description=Liberty+man+attends+National+Gala', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fwww.sentinelprogress.com%2Ftop-stories%2F13429%2Fliberty-man-attends-national-gala', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
		<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Liberty%20man%20attends%20National%20Gala&amp;body=https%3A%2F%2Fwww.sentinelprogress.com%2Ftop-stories%2F13429%2Fliberty-man-attends-national-gala" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>
				<div style="float:left; width:200px;  margin:7px;">
						<div>
		<img src="https://s24516.pcdn.co/wp-content/uploads/2019/11/web1_brown1.jpg" style="float:left; width:200px; margin-top:3px; margin-bottom:3px">
		Ethan Brown, left, and Ian Desmond, right. 		</div>
						<div>
		<img src="https://s24516.pcdn.co/wp-content/uploads/2019/11/web1_brown2.jpg" style="float:left; width:200px; margin-top:3px; margin-bottom:3px">
		Ian Desmond accepts the NF Champion award accompanied by Ethan Brown. 		</div>
										</div>
				<p>LIBERTY &#8212; The Children&#8217;s Tumor Foundation recently hosted the National Gala in New York City. This annual event draws philanthropists, donors, fundraisers, researchers, clinicians, NF patients and their families for an evening of inspiration, innovation, and awareness. In all, $2.5 million dollars was raised to support NF research endeavors.</p>
<p>And what does that have to do with Pickens County? Well, you&#8217;d have to ask Ethan Brown, a young man from Liberty.</p>
<p>Brown joined his best friend (and Colorado Rockies player) Ian Desmond in New York City last week for the Children&#8217;s Tumor Foundation National Gala.</p>
<p>Brown lives with neurofibromatosis type 2, a rare genetic disorder. Called NF2 for short, the disorder causes tumors to grow on nerves throughout the body. There is currently no cure.</p>
<p>Desmond and Brown have been friends since 2012, after striking up a friendship on the social media platform Twitter. Through their friendship, Desmond&#8217;s support for the Children&#8217;s Tumor Foundation has flourished.</p>
<p>And on Nov. 20, Desmond accepted the NF Champion award &#8212; with Ethan Brown by his side.</p>
<p>&#8220;Back in 2012, when I met Ethan (Brown), I didn&#8217;t know anything about NF,&#8221; Desmond said during his acceptance speech. &#8220;You all are world-changers. You&#8217;re fighters, you&#8217;re brave, you&#8217;re strong, you&#8217;re loving and you&#8217;re compassionate. I&#8217;m grateful to have seen all of this in action over the last seven years.&#8221;</p>
<p>Also during the gala, the launch of the Discovery Fund was announced. Discovery is an $8 million-dollar initiative supporting &#8220;the Foundation&#8217;s commitment to driving and funding the best and most promising NF research.&#8221;</p>
<p>Discovery Fund researchers will focus on NF drug development, including basic science to pre-clinical and early stage clinical trials, with the goal of developing new treatments and potential cures. &#8220;(The Discovery Fund will) trigger a new wave of discoveries that will lead to the next wave of clinical trials,&#8221; said Annette Bakker, Ph.D., Children&#8217;s Tumor Foundation president.</p>
<p>Founding members who have made a leadership commitment to the initiative, Shelley and Frank Haughton, Richard Horvitz and Erica Hartman-Horvitz, Jim Bob and Laur&#233;e Moffett, were recognized during the event and actor Alec Baldwin introduced Frank Haughton, who matched the first $900,000 raised in the research auction.</p>
<p>During his remarks, Frank drew on his personal connection to NF, &#8220;I am not a doctor. I am not a researcher, I am not going to discover a cure for NF. I am a dad, I am a granddad, but you know, moms, dads, grandmoms, granddads, we can be powerful, we can give of the resources that have been entrusted to us.&#8221;</p>
<p>The medical Humanitarian Award was given to Dr. Peggy Wallace, recognizing her numerous remarkable contributions to the field of NF research, most notably, as a member of the team that discovered the NF gene in 1991.</p>
<p>&#8220;Although NF has not yet been conquered, great strides have been made, and I have confidence that the future will definitely see an end to NF,&#8221; she said. &#8220;Science now has so many great tools that the bottleneck is funding, not ideas.&#8221;</p>
<p>The 2019 NF Ambassador McKinnon Galloway and 2009 NF Ambassador Rose Match Suna were also on hand to pass the torch to the upcoming Ambassador for 2020, Brianna Worden.</p>
<p>Brianna, now 22-years-old, was diagnosed with neurofibromatosis when she was two months old.</p>
<p> &#8220;As the 2020 National Ambassador, I hope to be an advocate for all people affected by NF,&#8221; she said. &#8220;This honor means the world to me and I cannot express how thankful I am. This is for all of you. Together, we can End NF!&#8221;</p>
<p>During their remarks, McKinnon and Rose unveiled the Junior Board, a group of young professionals committed to advancing the Children&#8217;s Tumor Foundation mission to drive research, expand knowledge and advance care for the NF community.</p>
<p>But perhaps the baseball player, with a friend from Liberty, said it best:</p>
<p>&#8220;All of the hard work the Children&#8217;s Tumor Foundation has poured into the last 40 years to change the world,&#8221; said Desmond. &#8220;I have no doubt that your fight will be a fruitful one, we will see a changed world, one without NF.&#8221;</p>
<style>
.neFileBlock {
	margin-bottom: 20px;
}
.neFileBlock p {
	margin: 0px 0px 0px 0px;
}
.neFileBlock .neFile {
	border-bottom: 1px dotted #aaa;
	padding-bottom: 5px;
	padding-top: 10px;
}
.neFileBlock .neCaption {
	font-size: 85%;
}
</style>
<div class='neFileBlock'>
<div class="neFile"><img class="neImage" src="https://s24516.pcdn.co/wp-content/uploads/2019/11/web1_brown1.jpg"></p>
<div class="neCaption">Ethan Brown, left, and Ian Desmond, right. </div>
</div>
<div class="metaInfo"><photo0>https://www.sentinelprogress.com/wp-content/uploads/2019/11/web1_brown1.jpg</photo0><caption0>Ethan Brown, left, and Ian Desmond, right. </caption0><photoCredit0>Courtesy photo </photoCredit0></div>
<div class="neFile"><img class="neImage" src="https://s24516.pcdn.co/wp-content/uploads/2019/11/web1_brown2.jpg"></p>
<div class="neCaption">Ian Desmond accepts the NF Champion award accompanied by Ethan Brown. </div>
</div>
<div class="metaInfo"><photo1>https://www.sentinelprogress.com/wp-content/uploads/2019/11/web1_brown2.jpg</photo1><caption1>Ian Desmond accepts the NF Champion award accompanied by Ethan Brown. </caption1><photoCredit1>Courtesy photo </photoCredit1></div>
</div>
<div class="metaInfo"><subheadMeta>Event raised $2.5 million for NF research</subheadMeta></div>
<div class="metaInfo"><bylineMeta></p>
<p>By Kasie Strickland</p>
<p>kstrickland@cmpapers.com</p>
<p></bylineMeta></div>
<div class="metaInfo"><shirttailMeta></p>
<p>Reach Kasie Strickland at 864-855-0355.</p>
<p></shirttailMeta></div>
		
		<div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.sentinelprogress.com%2Ftop-stories%2F13429%2Fliberty-man-attends-national-gala&t=Liberty+man+attends+National+Gala', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Liberty+man+attends+National+Gala:&url=https%3A%2F%2Fwww.sentinelprogress.com%2Ftop-stories%2F13429%2Fliberty-man-attends-national-gala', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.sentinelprogress.com%2Ftop-stories%2F13429%2Fliberty-man-attends-national-gala&media=https://www.sentinelprogress.com/wp-content/uploads/2019/11/web1_brown2.jpg&description=Liberty+man+attends+National+Gala', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fwww.sentinelprogress.com%2Ftop-stories%2F13429%2Fliberty-man-attends-national-gala', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
		<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Liberty%20man%20attends%20National%20Gala&amp;body=https%3A%2F%2Fwww.sentinelprogress.com%2Ftop-stories%2F13429%2Fliberty-man-attends-national-gala" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>
				<p>Reach Kasie Strickland at 864-855-0355.</p>			</div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://www.sentinelprogress.com/news/13426/breazeale-webb-win-city-council-runoff-races" rel="prev"><img width="80" height="60" src="https://s24516.pcdn.co/wp-content/uploads/2019/11/web1_webb-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" srcset="https://s24516.pcdn.co/wp-content/uploads/2019/11/web1_webb-80x60.jpg 80w, https://s24516.pcdn.co/wp-content/uploads/2019/11/web1_webb-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /><span>Previous</span><p>Breazeale, Webb win City Council runoff races</p></a></div>
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-next">
<a href="https://www.sentinelprogress.com/opinion/columns/13430/thanksgiving-2015" rel="next"><span>Next</span><p>Thanksgiving 2015</p></a></div>
</nav>
				<ins class="adbladeads" data-cid="35553-1462681351" data-host="web.adblade.com" data-tag-type="4" data-subid="sentinelprogress.com" data-protocol="https" style="display:none"></ins>
				<script async src="https://web.adblade.com/js/ads/async/show.js" type="text/javascript"></script>
				<a id="comments"></a>
				
<div id="disqus_thread"></div>
		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="custom_html-2" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Weather</span></h4><div class="textwidget custom-html-widget"><a href="http://www.accuweather.com/en/us/pickens-sc/29671/weather-forecast/335475" class="aw-widget-legal">
<!--
By accessing and/or using this code snippet, you agree to AccuWeather’s terms and conditions (in English) which can be found at http://www.accuweather.com/en/free-weather-widgets/terms and AccuWeather’s Privacy Statement (in English) which can be found at http://www.accuweather.com/en/privacy.
-->
</a><div id="awcc1460654628363" class="aw-widget-current"  data-locationkey="335475" data-unit="f" data-language="en-us" data-useip="false" data-partner="civitas" data-uid="awcc1460129762895" data-targeturl="https://sentinelprogress.com/weather"></div><script async type="text/javascript" src="https://oap.accuweather.com/launch.js"></script>
								<ins data-revive-zoneid="119" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
				<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script></div></div><div id="custom_html-5" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><ins data-revive-zoneid="56" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
				<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script>	</div></div><div id="custom_html-23" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><!---<div id="circularhub_module_12289"></div><script src="//api.circularhub.com/12289/965ff1dcb1a540d4/circularhub_module.js"></script>---></div></div><div id="custom_html-7" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget">	<ins data-revive-zoneid="57" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
				<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script></div></div><div id="custom_html-24" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">National Video</span></h4><div class="textwidget custom-html-widget"><div class="inform-embed"  data-type="VideoLauncher/Slider" data-tracking-group="92999"></div>
<script type="text/javascript">_informq.push(['embed']); vid.muted = true;</script>
<script src="https://launch.inform.com/js/embed.js"></script></div></div><div id="custom_html-9" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><ins data-revive-zoneid="58" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
				<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script>		</div></div><div id="custom_html-12" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget">	<ins data-revive-zoneid="59" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
			<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script>	</div></div>	</aside>	</div>
    </div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1">
<div id="media_image-2" class="mh-footer-widget widget_media_image"><a href="http://championcarolinas.com"><img width="300" height="81" src="https://s24516.pcdn.co/wp-content/uploads/2018/02/championwhite-300x81.png" class="image wp-image-9936  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" /></a></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2">
<div id="nav_menu-2" class="mh-footer-widget widget_nav_menu"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">General Information</span></h6><div class="menu-general-information-container"><ul id="menu-general-information" class="menu"><li id="menu-item-9943" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9943"><a href="https://www.sentinelprogress.com/advertise">Advertise with The Sentinel Progress</a></li>
<li id="menu-item-9944" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9944"><a href="https://www.sentinelprogress.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-9946" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9946"><a href="http://www.championcarolinas.com/terms/">Terms Of Service</a></li>
<li id="menu-item-9945" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9945"><a href="https://www.sentinelprogress.com/sign-up-for-notices">Sign Up For Daily Headline E-Mails</a></li>
</ul></div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3">
		<div id="recent-posts-3" class="mh-footer-widget widget_recent_entries">		<h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Latest Articles</span></h6>		<ul>
											<li>
					<a href="https://www.sentinelprogress.com/special-sections/13782/2020-medical-guide">2020 Medical Guide</a>
									</li>
											<li>
					<a href="https://www.sentinelprogress.com/news/13849/tigers-fend-off-morgan-state">Tigers fend off Morgan State</a>
									</li>
											<li>
					<a href="https://www.sentinelprogress.com/sports/13847/lady-blue-flame-basketball-season-was-full-of-highlights">Lady Blue Flame basketball season was full of highlights</a>
									</li>
											<li>
					<a href="https://www.sentinelprogress.com/opinion/13843/kids-have-to-make-names-for-themselves">Kids have to make names for themselves</a>
									</li>
											<li>
					<a href="https://www.sentinelprogress.com/opinion/columns/13841/a-roadmap-to-your-savings-journey">A roadmap to your savings journey</a>
									</li>
					</ul>
		</div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4">
<div id="text-2" class="mh-footer-widget widget_text"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Contact:</span></h6>			<div class="textwidget"><p><strong>Call:<br />
</strong>T:864-855-0355</p>
<p><strong>Address:<br />
</strong>201 W. Main Street<strong><br />
</strong>Easley SC, 29640<strong><br />
</strong></p>
</div>
		</div><div id="custom_html-22" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="text/javascript">
(function() {var s=document.createElement('script'); s.type='text/javascript'; s.async=true; s.src='//www.liqwid.net/?key=031A-9BE8-85CE-D8C0';var x=document.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);})();
</script></div></div></div>
</div>
</footer>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">
			2018 Champion Media		</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
<script type="text/javascript">
			var _gaq = _gaq || [];
			_gaq.push(['_setAccount', 'UA-6686294-10']);
						_gaq.push(['_trackPageview']);
			(function() {
			 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
			 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
			 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
			})();
		</script><script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"pickenssentinel"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24516.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"13429 https:\/\/www.sentinelprogress.com\/?p=13429","disqusShortname":"pickenssentinel","disqusTitle":"Liberty man attends National Gala","disqusUrl":"https:\/\/www.sentinelprogress.com\/top-stories\/13429\/liberty-man-attends-national-gala","postId":"13429"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24516.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://s24516.pcdn.co/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://s24516.pcdn.co/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var megamenu = {"timeout":"300","interval":"100"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24516.pcdn.co/wp-content/plugins/megamenu/js/maxmegamenu.js?ver=2.7.4'></script>
<script type='text/javascript' src='https://s24516.pcdn.co/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
</body>
</html>
<!-- Dynamic page generated in 0.118 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2020-02-29 19:40:08 -->

<!-- Compression = gzip -->